You are here

Error with Simile under Linux

I have the next error when i launch Simile under Linux:

Could not find a stub for Simile 3.3 and TclTk 8.4 under unix
while executing
"error "Could not find a stub for Simile $env(SIMILE_VERSION) and TclTk ${MAJ}.${MIN} under $tcl_platform(platform)""
(procedure "load_c_stub" line 10)
invoked from within
(procedure "ControlDraw" line 32)
invoked from within
"ControlDraw {GNU Prolog 1.2.16}"
invoked from within
"catch $args retVal"

Can anybody help me?

Thanks for all,


I think this is related to the c++ libraries installed on your system. Simile 3.3 is built with the version 2.96 c++ libraries. This has been out of date for some time but it is only recently that new Linux systems have stopped including them for backward compatibility. I assume you are running something fairly new like Fedora Core 2.

I'll try and post some new versions of Simile shared libraries on our website.


OK I've built a stub with the new libraries. Get it at and replace this file in System/lib/Stubs under the Simile directory. Please let me know if this works.


Hi, your library works. Thank u for all. I'm using Mandrake 10 with kernel 2.6 and gcc3+

Thanks again and sorry for my english



I'm trying to get simile to run on debian/sarge (upcoming 3.1), which is compiled with (afair) gcc 3.3. I get the same error as the poster above, however, that fix doesnt work for me.
If I copy that file over the old .so, nothing changes.

Would it be much work to provide a version that works with Debian? I would be happy to provide a shell-Account for testing purposes.

Greetings, Lukas Kolbe

Hello Makinux, your last message said you had it all working! What have you changed? Note we now have Version 4.0 available on the website...

This is Lukas, not Makinux. I just wrote it to this thread because it was the same error-message.
I think for Makinux on Mandrake 10 everything works fine, but for me on Debian/Sarge it doesnt work.

I'll give 4.0 a try tomorrow and report back to the forum, ok?


I really would like to try 4.0, but unfortunately under, where we got 3.3, there is no 4.0 to download ... Can you help me out?
I'm installing new machines for the students of Christian Ostertag-Henning.


Hello Lukas,

The teaching club editions are prepared a short while after the standard release, and will be available in the near future. In the meantime, you are welcome to use the evaluation edition to determine whether this release is suitable for your purposes.

We are not aware of any reason why the Debian distribution may be different in respect of the GNU C library. Please let us know if you experience the same problem with v4.0, and Jasper will continue the investigation, probably taking up your offer of a user account.

Kind regards,
Alastair Davies

Ok, I'll try the evaluation-version.

But, if I see this correctly, simile under linux is compiled with gcc 2.96? If so, then I wonder why other people don't have similar problems, because gcc 2.96 was never officially supported and is not binary compatible with gcc 2.95 nor gcc 3.0, 3.1, 3.2, or any other gcc version. Especially with c++ there a massive amounts of problems.
Redhat began to ship a modified development-version of gcc 2.96, which was a big mess that time.


I think it worked because a lot of distributions included compatibility libraries for that version of gcc. However Simile v4 is built with gcc version 3.33 (at least the bits that we build ourselves are, some of the binaries come from the precompiled TclTk 8.4.7 distribution). I'll happily create binaries on request for people who want to run it with older c and c++ libraries and post them here.

Excellent, thank you very much. Gcc 3.3 is also the default in Debian.
I know it sucks writing closed-source software for open-source systems because of these very reasons :). I'll try it out soon.


Simile 4 Evaluation works very well under Debian. The problem that we have now is that on the 12. Octobre we start a lecture teaching simile, and until now used the Teaching-Licence of Simile 3, which doesn't work on the new Systems. Could you provide us either a Simile 3 compiled with gcc 2.95 or 3.3 (not gcc 2.96) or a Teaching-Licence-Version of Simile 4? That would help us very much.

Thanks in Advance,
Lukas Kolbe

OK, I have put a teaching version of Simile 4.0 on the site. However, you will need a license code to run it -- please send me a personal mail (to jasper (at) with your name and institution name as you wish them to appear on the splash screen, and I will send you the license string to edit into your userinfo.txt file.

Also note this version is time-limited to the end of the year; we are currently debating whether the teaching version should differ in some way from the standard version, and do not wish to make an open-ended version available until we have settled this question.