You are here

Any results for MacOS Leopard?

Hi folks, I've been reading reports that some versions of TclTk have issues under MacOS 10.5 (Leopard). Is there anyone here who could do a check as to whether the current Simile (any edition) runs properly under that OS? The problem, if it existed, would occur during file selection dialogues.


Unfortunately, Simile 4.9 Standard does not work at all on my new computer running Mac OS X 10.5... The application quits immediately after launching. The same problem occurred with Simile 5.0 Evaluation.
What should I do?

Hi Francois...I´m planning to get a new Mac with OS 10.5 myself in the next couple of days, after which I will be able to work on this problem, thanks for posting -- Jasper

I got my Leopard machine and installed Simile 5.0 eevaluation on it, and it ran OK apart from noot having the c++ compiler available. I installed this from installation disk 1 that came withh the machine, and it all worked OK. Notee tht when you install Xcode Tools, you have t selct the ooption to install Unix development tools in order that the compileer be put in a location where Similee finds it.
Francois, can you give me more details of your osx 10.5 machine and the problem you have running Simile? Try running it from the command prompt, by openiing a terminal, changinng directory to Simile annd typing ./Simile --- thi should produce an error message which mighht be useful iff it fails to start.

I have installed Xcode Tools, but the problem remains. Here is the error reported by ./Simile --- thi:

Error in startup script: no suitable image found. Did find:
/Users/bogillet/Library/Tcl/tclAE2.0/Contents/MacOS/tclAE2.0.dylib: mach-o, but wrong architecture
NSCreateObjectFileImageFromFile() error: not a Mach-O MH_BUNDLE file
while executing
"load /Users/bogillet/Library/Tcl/tclAE2.0/Contents/MacOS/tclAE2.0.dylib"
("package ifneeded" script)
invoked from within
"package require tclAE"
invoked from within
"if {[string match Darwin $tcl_platform(os)]} {
set auto_path [ $SIMILE_PATH/../Frameworks/Tcl.framework/Resources/Scripts $SIMILE_PATH/../Fram..."
(file "/Applications/Simile" line 70)
invoked from within
"source [file join [file dirname [info script]] ../Run/simile.tcl]"
invoked from within
"if {[file exists $script]} {
# MacOS attempt to start executable proc with a script
set argv [lrange $argv 1 end]
source $script
} else {
(file "/Applications/Simile" line 3)

Perhaps it could help you, but not me...


Thanks very much for digging up that error message; it's interesting but sadly does not lead me directly to a solution. Could you tell me more about your machine? Particularly, is it Intel or PPC, 32- or 64-bit? Which model?

Hi Jasper,
Thanks for your answer. My machine is a MacBook Pro, Intel 32-bit, with 2 GB RAM and Mac OS X 10.5.2.
The problem arises for both Standard Edition 4.9 and Evaluation Edition 5.0.
I suspect a localization problem, since it became sometimes very difficult to install Simile on Swiss French systems. In the Windows XP environment, I had to run Simile under a new user account to be able to use it...

I am running OS 10.5 and Simile evaluation version 5.0 in the US and it seems to be working fine - though perhaps I don't know enough yet to know the difference. The file dialog box seems to work. I installed Xcode 3.0 tools and now the "model / run" process works - whereas before I installed Xcode I got an error.

Finally, I've found out why Simile could not run on my MacBook Pro with Leopard: there were an old tcl folder in my home directory which was installed during the migration from my old PowerBook. After deleting this folder, Simile worked fine!